It keeps "checking answer"... :(

Does it really help if I donate, even if I only pay, let's say... 1$? 'Cause if the problem gets better for me after I've donated, I'll consider it. :/

And, out of curiousity, does anyone else have this problem?
posted by Gibiya

Comments 11

  • beeant
    beeant
    I'm sorry for the problem you encountered, I just did some tweaks on the database settings. Do you still have this problem?
  • mog86uk
    mog86uk
    I get this often. Some days it happens every few questions, other days I can do Practice for hours without it happening even once.

    I haven't figured out if it happens more often when more people on the site (heavy server load), or if it just happens more at certain times of the day / certain days of the week (network conditions).

    Donating $1 won't instantly fix the problem for just yourself, like some kind of special pass, although the message might sound a little bit like it's offering that. :P

    If a lot more people had already donated just a little bit, then we'd not have this problem in the first place -- as we'd be on a more powerful server, and Beeant, who has to pay with his own money to keep the site up, could afford to spend more time on the site instead of his other projects.

    At the moment, only 99 out of the 50,000 user accounts on this site have donated! If everyone who liked the site had already taken just 1 minute to donate even just $1, then this awesome site would probably be much more awesome than it is now. ^^
  • beeant
    beeant
    Hello Gibiya,

    Thank you very much for your consideration to donate.

    Currently JCJP is collecting donation to continue the development and to pay for the costs of technical infrastructures such as server hosting. I hope the donation can be some sort of crowd funding.

    With donation, you will contribute to the development of JCJP and to keep JCJP running. Frankly, with $1, it is not enough to directly affect the performance and quality of JapaneseClass.jp. JCJP needs more funding to accelerate the development, also to improve overall performance and quality.

    Please consider to donate if you love JapaneseClass.jp, because I love JapaneseClass.jp too, would really love to keep on developing and improve it.

    Thank You,
    beeant
  • beeant
    beeant
    mog86uk how about now? do you still encounter this problem? I personally have this problem, but they're mostly when it's loading for the next question. The problem to this is because I have a lot of items in weak & oblivion list. So the computer needs to find which question needs to be shown to me next, as the question selection is personalized.

    Thank you for re-explaining what I am trying to say. I have to put a title in your profile statistics page as Community Manager.

  • mog86uk
    mog86uk
    I just did 20 minutes of Practice, with 91 oblivion words when I started, and I stopped Practice once my oblivion list was naturally cleared -- 240 questions later. I didn't encounter this problem once. Nearly every question loaded instantaneously, but I don't know if this was just because the site is running well at the moment?

    I kept the practice settings on their defaults, except I had 'show kana' deselected (which I always deselect).

    I guess, would it be more interesting if I manage to encounter this problem now that my oblivion list is clear?
  • mog86uk
    mog86uk
    Interesting. So the problem is linked to the site trying to figure out what question to load next if you have lots of oblivion and weak words?

    I almost never have any weak words. I completely cleared my oblivion list a few days ago too. If I have no weak or oblivion words, does that mean that this problem shouldn't happen for me?

    I don't know if I've had the problem since I cleared my oblivion list. However, I think this problem also occurs when doing things like Lessons, where the oblivion and weak lists shouldn't really matter?

    I haven't done Practice yet today, and my Oblivion has gone back up to 91 since yesterday, but I'll see if I still get this problem before and after I clear the list. ^^
  • beeant
    beeant
    It's not 100% caused by this problem, there are also many other aspects, such as you mentioned, heavy load on the server. Just imagine the server needs to analyze each user data to give out personalized question.

    After I did the tweak, it seems that the question loads fine. Although there still some big lag sometimes, it's still tolerable, unlike before. Please let me know again if you are still experiencing this problem.

    Also, do you get notification for this reply? because I don't get any notification after you posted the 2 replies before this reply.
  • Gibiya
    Gibiya
    Thank you for the answers! I have indeed experienced that it happens more often during some hours of the day than others, so it has probably a lot to do with the server traffic, to me at least. I'll try the 'Save settings' trick next time. Always worth a try, hehe c:
  • mog86uk
    mog86uk
    I encountered the message about 15 minutes ago while doing Practice. It was at 'loading question' that it stopped and the message came up, not at 'checking answer'. As you said, I think for me it is usually at 'loading question' that this message appears, however I'm sure I've had it happen on 'checking answer' too.

    At least I can confirm it definitely still happens to users even if they have no oblivion + no weak + no new words.

    A couple of things:

    ・It would be nice if the 'refresh' button in this message at least actually remembered your Practice settings. Before, I've clicked it, then had to deselect 'show kana' again, only to have it get stuck again on 'loading question' after clicking 'save settings'. >_<

    ・If you notice that it's going to get stuck on 'checking answer' or 'loading question' (i.e. you it still hasn't changed after 5-10 seconds), then if you click 'Settings' and just click 'Save settings' it usually loads a new question instantly! even though it would have failed if you didn't do this.

    However, after clicking 'Save settings' and answering a few questions, the message STILL comes up after exactly 60 seconds have passed from when it got stuck! I've done this trick twice within 60 seconds and ended up with two messages popping up while I'm answering other questions... :P
  • shinbosai
    shinbosai
    just out of curiosity, how much does it cost per month to keep this website running?
  • mog86uk
    mog86uk
    I'm interested in this too. I've said before that it would be easier to visualise if we could see A) how much site hosting cost is per year (or month I guess), and B) the total donations specifically for the current year (or month).

    The site has moved server a few times in the last few months. I'm pretty certain that the 'Server Cost per year' listed on the donation page is not correct for the current server. However, donations definitely haven't covered server costs since the site began (about 6 years ago?) either. There may be other costs for separate web services too, I don't know.

    It would definitely help to have some more accurate figures which people could understand easier. @beeant. :)
Gibiya

Share