Hide furigana in Readings quizzes.

Here's a userstyle I made and have been using for a long time for hiding furigana in the Readings quiz questions:

https://userstyles.org/styles/154461/jcjp-readings-furigana-hide

The browser extension "Stylish" or a similar extension is needed in order to use it. I've always kept "Show Kana" turned off in the Practice feature settings. This userstyle is the Readings feature equivalent of that setting. I think getting used to not relying on furigana is a very important part to reading the questions much faster. ^^
posted by mog86uk

Comments 9

  • ellascott
    ellascott
    I feel like learning Japanese through very effective and interesting games https://www.hotmailsigninguide.com
  • memorybread
    memorybread
    How do you turn off the show kana and romanji in practise and lessons? The settings for practise are blank when viewed on iPhone and there are no settings for lessons. It’s driving me nuts! I wasted 30mins of my practise today trying to find a setting!
  • mog86uk
    mog86uk
    There isn't a setting for turning off "show kana" in the lessons; only for the Practice feature has this option.

    However, for people on desktop web browsers, if they've got a browser extension for running userstyles (such as "Stylus") they can get the following userstyle I made to turn off "show kana" in the lessons. ^^

    https://userstyles.org/styles/130859/jcjp-vocab-test-yomigana-disabler-mog86uk

    Can't help mobile web browser users for this though.

    - - -

    As for turning off "show kana" in the Practice feature on a mobile browser, though I use Android (Google Chrome), I think the following instructions might help with the problem you're encountering:

    On the Practice page, FIRST click the three red dots icon in the top-right corner of the page. This should display the "online users" list. THEN, after that, the "settings" button should work correctly. Deselect "show kana" and click "save settings", and then the kana should be gone.

    Hope this works for your iPhone. ^^
  • memorybread
    memorybread
    Nope, it doesn’t.
  • mog86uk
    mog86uk
    @memorybread, That's a shame. :(

    Ticking the "desktop site" option in Chrome menu on Android phones works perfectly fine to show the desktop version of this site. I'm surprised this isn't working either on iPhones.

    One other thing you could try is to scroll down the Practice page to see if the settings popup is appearing further down. This is a part of why it's not appearing correctly.

    It needs fixing anyway. It probably affects all browser on all phones. I don't think it's anything complicated that's causing it not to appear. Beeant (admin/owner/developer of this site) just needs to be made aware that this problem exists.
  • memorybread
    memorybread
    The desktop setting gets ignored by this site on iPhone Chrome and Safari. Even using iCabMobile and changing browser string makes no difference. The site "intelligently" adjusts to browser width to handle different screen sizes and disables our ability to override that, and also disables the ability to zoom text in Chrome (but not Safari). You were right though - the popup does appear if you scroll right to the bottom of the page, so the location of it is the issue on Practise. However it doesn't remove the roma(n)ji from Lessons. Ideally there would be one setting site wide - and since the site insists everyone does Level 1, ideally that setting would apply to Level 1 lessons also.

    The Account Settings page also has issues. On iPhone it always gives and XML response of failure displayed on the webpage. On desktop, despite changing my location to Japan, on some browsers it still shows me as USA and when I go to account settings it defaults me to USA again - yet on other browsers it is OK. So I am guessing its a cache issue.
  • mog86uk
    mog86uk
    Ah. Just checked the "desktop site" option again. It's not actually showing the site in desktop view. When I tried it earlier I mistakenly thought it looked like it had made the page wide enough to get out of mobile view. So you're right that this doesn't help.

    Yeah, the settings button on the Practice page only affect the Practice feature. The lessons haven't been designed to have user configurable settings.

    As for the location setting, it is always ignored. The site shows the user's country automatically via IP address. I think the location setting is only meant to take effect if the site can't find any country matching your IP address. For me at least, it's been showing your location as being in Japan the whole time. It's still showing a Japanese flag for you. ^^
  • memorybread
    memorybread
    That (maybe) explains that then, although I'd expect my work internet to be going through HK or India rather than US. There is still the XML response issue on that page though.

    I must say that despite some minor quibbles, the site is really well designed. Forums need a better - any - spam filter though. Even just ensuring poster has 100 experience points would probably do it to block the casual spammer.
  • mog86uk
    mog86uk
    I haven't encountered that problem on Android. Just tried the account settings page and it all seems to work correctly with no issues.

    I agree about something like a 100 EXP requirement for posting. Even just 1 EXP is probably enough. We've talked many times in the past about something like this. Sadly, the plague of advertising spam bots have long been a problem on this site. :/
mog86uk

Share